[alsa-devel] [PATCH] ISA: New Aztech Sound Galaxy driver

René Herman rene.herman at gmail.com
Wed Aug 11 14:37:03 CEST 2010

Hi Takashi.

I've dusted of the snd-galaxy Aztech Sound Galaxy driver that I posted 
back in 2007. Have not been around for a long time but found some time 
again currently. Earlier this year I was contacted about the driver so 
there's still at least some demand for it.

It is the same version as posted way back then:


only brought up to date to 2.6.35, and with lib.c folded back in to fix 
the remaining problem from the earlier post.

It's also been tested again on all previously tested cards and two new 
ones. Everything still found working. More information in the changelog 
accompanying the patch below.

Cleaning up and moving AZT2320 to the galaxy directory as well would be 
a next step, as would removing the old sgalaxy driver.

The patch has been generated against 2.6.35 and I've just now checked 
that it applies cleanly to current git. Hope that'll do since I'm not 
really setup to work against alsa-driver or anything. When updating the 
driver I noticed fairly little seems to have happened inside sound/isa 
anyway over the last few years, so I assumed it would be okay.

Hope it can be applied as is, but I have some time to deal with problems 

@ Ram: Do you even still have the card? ;-)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-ISA-New-Aztech-Sound-Galaxy-driver.patch
Type: text/x-patch
Size: 0 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20100811/30575574/attachment-0001.patch 

More information about the Alsa-devel mailing list