[alsa-devel] patch_nvhdmi.c's snd_hda_preset_nvhdmi[] formatting, entry naming, new entries

Stephen Warren swarren at nvidia.com
Mon Aug 9 20:47:26 CEST 2010


I'm working on a patch to add some new codec IDs to patch_nvhdmi.c. I notice
that many lines in that table are wrapped to avoid long lines. Is there a hard
80 column limit for ALSA driver or kernel files? I'd find the table and diff
much easier to read if I could simply put each new entry on a single line,
but don't want to violate any hard-and-fast coding style rules...

Second, I wish to add entries for some GPUs that haven't yet been released.
For these, I'd like to make the codec names simply "GPU HDMI/DP", since I
can't expose naming for unreleased products. We'd like to get these entries
into the driver early so that they're available in distros before products
ship, so that the hardware "just works" out of the box. Indications so far
are that these devices will simply be standard Azalia codecs, and hence not
need any code/tables/quirks to operate correctly (i.e. they'll follow the
existing "MCP89" path).

Finally, the naming for existing discrete GPU entries (GT220/GT21x/GT240) is
a mixture of engineering GPU names and marketing names. I'd like to edit these
names to also be simply "GPU HDMI/DP" for consistency. Unfortunately, I'm not
allowed to submit engineering GPU names for any GPUs, and using marketing
names in these entries doesn't make sense, since there may be multiple
marketing names per codec ID, and the marketing names many change over time.

Does anyone have any problems with any of the above before I submit a proposed



More information about the Alsa-devel mailing list