[alsa-devel] ALC269 mixer nodes

Takashi Iwai tiwai at suse.de
Tue Aug 3 09:18:24 CEST 2010

At Tue, 03 Aug 2010 08:49:05 +0200,
David Henningsson wrote:
> 2010-08-02 16:50, Takashi Iwai skrev:
> > At Mon, 02 Aug 2010 16:30:57 +0200,
> > David Henningsson wrote:
> >>
> >> Here's yet another ALC269 which I'm unsure of how to fix the right way.
> >> There is no way to enable the microphone, and I think the trouble has to
> >> do with that the auto parser does not check whether the node is a mixer
> >> or a selector. It might be that the "alc269" vs "alc269vb" detection is
> >> wrong as well (btw, what does vb stand for?).
> >>
> >> I unfortunately do not have the full alsa-info output, but the
> >> codec-proc is here:
> >> http://launchpadlibrarian.net/49076615/Card0.Codecs.codec.2.txt
> >> and PCI IDs:
> >> http://launchpadlibrarian.net/49076618/PciMultimedia.txt
> > 
> > Are you sure that it's the result with the very latest driver?
> The codec-proc might not have been generated with the very latest
> driver, but when I run it through hda-emu (with a just-pulled
> sound-2.6.git as hda-dir), I get errors as:
> send: NID=0x23, VERB=0x701(set_connect_sel), PARM=0x1
> invalid connect select for node 0x23
> ...which makes me believe the error is still there. The error above
> comes from patch_realtek.c:14366, btw.

This isn't a critical bug.  The codec shall ignore this verb.
(of course it should be corrected, though.)

The capsrc should have been initialized via fixup_single_adc() in this
case, and hda-emu gives the right result, too.  So I wonder whether
this issue still exists.



More information about the Alsa-devel mailing list