[alsa-devel] usbaudio: Support for USB audio v2.0 devices

The Source thesourcehim at gmail.com
Tue Apr 27 15:31:35 CEST 2010

27.04.2010 17:23, adelias пишет:
> On 2/3/2010 8:35 μμ, Daniel Mack wrote:
>> On Tue, Mar 02, 2010 at 11:13:04AM +0200, adelias wrote:
>>> Thanks to all involved for working on usb audio v2.
>>> Last night I installed the 20100226 snapshot. I did a little testing
>>> with my XMOS board using toslink out into may DAC. I tried various files
>>> ranging 16bit/44110kHz-24bit/192000kHz. The 44110 files had quite a bit
>>> of static, the higher bitrate files were better. As you stated the
>>> sampling rate is not correct and be verified by looking at the flashing
>>> LEDs on the XMOS board. They should flash faster as sampling rate
>>> increase. In this case no change was observed.
>> Yes - this is all do be done. The sample rate setting is done with a
>> different type of class request, which also addresses the interface now,
>> unlike v1 devices which send that to the endpoint. But that's just one
>> out of many differences that need to be addressed, and it's still a long
>> way to go. I'm on it :)
>> Daniel
> I upgraded alsa to 1.0.23. The XMOS device is working great with the
> exception of some mild clicks here and there. Is this a known issue or
> might it be a problem with my specific configuration?
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at alsa-project.org
> http://mailman.alsa-project.org/mailman/listinfo/alsa-devel
Perhaps I should've posted my problem in this thread earlier. Here's the 
Creative X-Fi Notebook stopped working after upgrading from to 
1.0.23 (worked just fine before).
dmesg gives the following:

usb 8-2: new full speed USB device using uhci_hcd and address 2
usb 8-2: New USB device found, idVendor=041e, idProduct=30d2
usb 8-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 8-2: Product: SB X-Fi Notebook
usb 8-2: Manufacturer: Creative Technology Ltd
usb 8-2: configuration #1 chosen from 1 choice
input: Creative Technology Ltd SB X-Fi Notebook as 
generic-usb 0003:041E:30D2.0002: input,hidraw1: USB HID v1.11 Device 
[Creative Technology Ltd SB X-Fi Notebook] on usb-0000:00:1d.2-2/input3
input: Creative Technology Ltd SB X-Fi Notebook as 
generic-usb 0003:041E:30D2.0003: input,hidraw2: USB HID v1.11 Keyboard 
[Creative Technology Ltd SB X-Fi Notebook] on usb-0000:00:1d.2-2/input4
ALSA pcm.c:174: 2:1:1: endpoint lacks sample rate attribute bit, cannot 
ALSA pcm.c:174: 2:2:1: endpoint lacks sample rate attribute bit, cannot 

Additionally, modprobe never exits after connecting the device using 
100% CPU and disrupting system's work.

More information about the Alsa-devel mailing list