[alsa-devel] [PATCH 1/4] pxa: add namespace on ssp

Mark Brown broonie at opensource.wolfsonmicro.com
Thu Apr 22 02:08:18 CEST 2010

On Thu, Apr 22, 2010 at 06:17:29AM +0800, Eric Miao wrote:
> On Sat, Apr 17, 2010 at 1:34 PM, Haojian Zhuang

> > In order to prevent code ambiguous, add namespace on functions in ssp driver.

> Sorry I'm still not convinced that this is a necessary change, could
> you point me to some place where there are naming conflicts?

Oh, sorry - misread the patch that was being replied to.  The issue is
more around consistency and the fact that ssp_ is pretty short as it is
about specific conflicts that exist.  If the rest of the driver had been
using ssp_ already I wouldn't have said anything but since currently
exported symbols all use pxa2xx_ it seemed better to make newly exported
ones match.

More information about the Alsa-devel mailing list