[alsa-devel] hda_intel: SPDIF not detected on Asus P7P55D PRO

Takashi Iwai tiwai at suse.de
Mon Sep 21 15:38:03 CEST 2009

At Fri, 18 Sep 2009 08:38:26 -0600,
Robert Hancock wrote:
> On Fri, Sep 18, 2009 at 12:18 AM, Takashi Iwai <tiwai at suse.de> wrote:
> > At Thu, 17 Sep 2009 21:38:04 -0600,
> > Robert Hancock wrote:
> >>
> >> I just set up a new system running an Asus P7P55D PRO motherboard. It
> >> looks like this uses the VIA VT1828S codec. The analog output seems to
> >> work but the SPDIF output isn't recognized. Originally tried,
> >> but Linus' current git doesn't seem any different. The device only gets
> >> detected as HDA Generic, which, from my reading of the code, ignores
> >> SPDIF outputs. I tried hacking patch_via.c to add the codec ID to match
> >> existing types like VT1708S and VT1702, each of those got the SPDIF
> >> output to show up, but no output showed up on the receiver, and also the
> >> analog output then stopped being recognized (looks like some node IDs
> >> don't match).
> >
> > Could you give alsa-info.sh output (run with --no-upload option)?
> Here it is:

Thanks.  This looks really incompatible with the existing VIA codecs.
So, no wonder that you didn't get it working by a simple hack.

Right now, VIA codec parser assigns the DAC based on the fixed list
instead of parsing the widget connections.  There is a room for
improvement here, but I have no time as now to fix it...

Harald, do you know anyone who can help the development for this new
codec chip?



More information about the Alsa-devel mailing list