[alsa-devel] Fwd: Dell Studio 14, internal mic

Alistair Boyle alistair.js.boyle at gmail.com
Thu Sep 17 21:51:55 CEST 2009

2009/9/17 Takashi Iwai <tiwai at suse.de>:
> At Thu, 17 Sep 2009 13:25:22 -0400,
> Alistair Boyle wrote:
>> On Thu, Sep 17, 2009 at 12:31 PM, Takashi Iwai <tiwai at suse.de> wrote:
>> > At Wed, 16 Sep 2009 17:18:11 -0400,
>> > Alistair Boyle wrote:
>> ...
>> >> 2. It should be the "capture" control that Skype or some other
>> >> application should be twiddling to adjust recording volume
>> >> automatically? Is it this control that should come first when they are
>> >> enumerated, or is there some property that is missing from this
>> >> control to tell the application which control to use? (ie: is there
>> >> anything the alsa-driver does to help the application get this right?)
>> >
>> > The "Capture" volume is available.  Skype should choose it as default.
>> > Isn't it just the old saved setup that screws up?
>> Clearing ~/.Skype and restarting gets the same behavior. Skype is
>> playing the "front mic" control instead of "capture". I see a bunch of
> Hm, then it's rather a problem of Skype.

Okay. Thanks for all your help so far!

>> >> 1. The "pc beep" is still making a bad buzz/crackling noise when an
>> >> xterm beep occurs. There's also a new "speaker" control but it doesn't
>> >> affect this behavior (unrelated?).

>> > Hm, this is basically independent from my change, and I guess this is
>> > a codec hardware issue.

The last item was the "pc beep" thing. It looks like you're the guy to
talk to about that too: is there any debugging I can do on my end to
help sort that out? It looks from the log like there's some tricky
business with getting the beep frequency right?

More information about the Alsa-devel mailing list