[alsa-devel] Alsa plugin unable to be loaded by Pulseaudio

Lennart Poettering mznyfn at 0pointer.de
Wed Sep 9 15:59:39 CEST 2009

On Wed, 09.09.09 21:16, Ng Oon-Ee (ngoonee at gmail.com) wrote:

> The "test" device is defined as follows (should have put it in
> initially).
> pcm.test {
>  type plug
>  slave { pcm "hw:0,0" }
> }
> It works with aplay. My issue is that the pulseaudio server cannot load
> alsa plugins since 1.0.20 (as far as I can tell, ubuntuforums has a
> thread which suggested as such). When I queried the pulse ML, Lennart
> posted the below reply, which I've forwarded here to alsa-devel.
> Basically, the issue as Lennart sees it is summarized by his last 3
> paragraphs (bottom of this mail). He specifies the difference between
> the way alsa is reacting to pulse and the way it 'should'.

After the discussion we had on alsa-devel about the ordering how buffer
size and period size are initialized i have now changed PA git to try
harder to initialize those values. Would be good if you could check if
that actually makes your problem go away.


Lennart Poettering                        Red Hat, Inc.
lennart [at] poettering [dot] net
http://0pointer.net/lennart/           GnuPG 0x1A015CC4

More information about the Alsa-devel mailing list