[alsa-devel] SB X-Fi driver still fails with Kernel 2.6.31-9 + ALSA 1.0.21

David Favor david at davidfavor.com
Tue Sep 1 20:01:05 CEST 2009

I'm using Ubuntu + Kernel 2.6.31-9 + ALSA 1.0.21 from today.

For the X-Fi CA0110 card I have the codec stanzas are missing.
I've built ALSA with --debug=verbose so if anyone has any idea
what I can do to debug this problem, let me know.


david at home1:~/bin$ uname -a
Linux home1 2.6.31-9-generic #29-Ubuntu SMP Sun Aug 30 17:39:23 UTC 2009 i686 GNU/Linux

david at home1:/etc/pulse$ lspci | grep -i audio
0d:00.0 Audio device: Creative Labs [SB X-Fi Xtreme Audio] CA0110-IBG

david at home1:/etc/pulse$ lsmod | grep -i ca0110
snd_hda_codec_ca0110     7772  1
snd_hda_codec          81884  2 snd_hda_codec_ca0110,snd_hda_intel
snd                    65092  22 
snd_hda_codec_ca0110,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss, \

david at home1:/etc/pulse$ modinfo snd-hda-codec-ca0110
filename:       /lib/modules/2.6.31-9-generic/updates/alsa/pci/hda/snd-hda-codec-ca0110.ko
description:    Creative CA0110-IBG HD-audio codec
license:        GPL
alias:          snd-hda-codec-id:1102000d
alias:          snd-hda-codec-id:1102000b
alias:          snd-hda-codec-id:1102000a
srcversion:     32AD360281DB96C479EA380
depends:        snd-hda-codec,snd
vermagic:       2.6.31-9-generic SMP mod_unload modversions 586

david at home1:~/bin$ audio-codecs
Codec: Creative CA0110-IBG
Address: 1
Function Id: 0x1
Vendor Id: 0x1102000a
Subsystem Id: 0x11021007
Revision Id: 0x100000
No Modem Function Group found
Default PCM:
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
GPIO: io=255, o=255, i=255, unsolicited=1, wake=1

Love feeling your best ever, all day, every day?
Click http://RadicalHealth.com for the easy way!

More information about the Alsa-devel mailing list