[alsa-devel] [PATCH] remove OSS Ensoniq SoundScape driver

Takashi Iwai tiwai at suse.de
Fri Oct 30 12:48:22 CET 2009

At Sat, 24 Oct 2009 17:47:33 +0200,
Krzysztof Helt wrote:
> From: Krzysztof Helt <krzysztof.h1 at wp.pl>
> The OSS driver for Ensoniq SoundScape cards is broken after conversion
> to mutexes and a new ALSA snd-sscape driver handles all devices handled 
> by the OSS one.
> The ALSA driver was tested with these cards:
> Spea V7 MediaFX
> Ensoniq Soundscape Elite
> Ensoniq Soundscape VIVO (this card is not handled by the OSS driver)
> Signed-off-by: Krzysztof Helt <krzysztof.h1 at wp.pl>

If OSS driver is broken, no worth to keep it indeed.
I applied the patch now.  Thanks.

> ---
> Theodore Allen confirmed that that the new driver works for his 
> Ensoniq Soundscape Elite card (both MIDI and PCM):
> "I decided to upgrade to from 2.6.28.
> I also put the firmware in the /lib/firmware directory.
> Now the MIDI seems to work on most files.  There are
> a few that sound odd, but perhaps it's the midi map.
> I have no idea why the driver allowed the sscape_ctl
> program to load the firmware earlier, but it doesn't now.
> Was there an ALSA change between 2.6.28 and
> Less happily, the sound seems now to have a very faint
> "zzzt" kind of "click" just before playing, which I think
> it didn't with 2.6.28.  I'll verify that after I
> reboot into the old kernel."
> I will investigate the PCM issue after he confirms that it is a regression. 
> This allows closing the ALSA bug #2234.

Great.  Thanks for your work!


More information about the Alsa-devel mailing list