[alsa-devel] Problems with newest alsa driver on 2.6.30 kernel - unknown symbols

Christian Steffen c-steffen at web.de
Sun Oct 18 17:47:23 CEST 2009

Tried it with the older version 1.0.20, which still gives me one error:

[  190.555043] snd_hda_codec: Unknown symbol snd_hwdep_new

Is there anything to change in the kernel config or whatever?

-----Ursprüngliche Nachricht-----
Von: alsa-devel-bounces at alsa-project.org
[mailto:alsa-devel-bounces at alsa-project.org] Im Auftrag von Christian
Gesendet: Sonntag, 18. Oktober 2009 16:45
An: alsa-devel at alsa-project.org
Betreff: [alsa-devel] Problems with newest alsa driver on 2.6.30 kernel -
unknown symbols

Hi there,

while an older version of alsa drivers is working fine with my kernel
2.6.30, the newly compiled modules can't be inserted properly.
I compiled snd-had-intel modules for my kernel 2.6.30 and tried to
insert/start them.

dmesg returns me:

[  106.209451] snd_hda_codec: Unknown symbol __snd_printk
[  106.210340] snd_hda_codec: Unknown symbol snd_hwdep_new
[  106.212211] snd_hda_codec: disagrees about version of symbol
[  106.212217] snd_hda_codec: Unknown symbol snd_pcm_hw_constraint_step

Any idea?


Alsa-devel mailing list
Alsa-devel at alsa-project.org

More information about the Alsa-devel mailing list