[alsa-devel] [PATCHv3 1/7] OMAP4: PMIC: Add support for twl6030 codec

Lopez Cruz, Misael x0052729 at ti.com
Thu Oct 8 03:30:29 CEST 2009

Krishnamoorthy, Balaji T wrote:

> CONFIG_TWL6030_CORE and CONFIG_TWL4030_CORE is merged to
> CONFIG_TWL_CORE As two different build config was not encouraged. 
> Now switch twl_class_is_6030() will be used to decide at runtime time
> to support for 6030 related drivers, Similarly twl_class_is_4030()
> for 4030 drivers 

In patch "[PATCH v3 01/04] OMAP4: PMIC: Add support for twl6030 irq
framework" [1], TWL4030_CORE is redefined as TWL_CORE as you mentioned.
Then I guess that audio drivers should depend on TWL_CORE as well, if so
then we have to update all its dependencies:

1. TWL4030 codec driver: SND_SOC_TWL4030
2. All machine drivers using twl4030 codec driver: overo, omap2evm,
   omap3evm, sdp3430, omap3_pandora, omap3_beagle and zoom2

And I should do the same for twl6030 codec driver.


[1] http://www.mail-archive.com/linux-omap@vger.kernel.org/msg17066.html

More information about the Alsa-devel mailing list