[alsa-devel] ascenario: Small updates for new API.

Stefan Schmidt stefan at datenfreihafen.org
Wed Oct 7 15:55:55 CEST 2009


[PATCH 1/3] ascenario: Rename SND_SCN_INT_QOS to SND_SCN_INT_QOS_POWER
As proposed by Jaroslav. Emphasis the power consumption relationship.

[PATCH 2/3] ascenario: Fix snd_scenario_get_control_id() declaration to match implementation
Just different names in declaration and implementation. I favoured

[PATCH 3/3] ascenario: Implement snd_scenario_get_control_id()
Replace the four explicit functions with a generic one. I was not able to find
another way to get the id from the given numid then getting the full list and
iterate through it. If there is something easier let me know. :)

Stefan Schmidt

More information about the Alsa-devel mailing list