[alsa-devel] [PATCH] ascenario: Add scenario support to alsa-lib
stefan at datenfreihafen.org
Wed Oct 7 15:48:09 CEST 2009
On Tue, 2009-10-06 at 15:46, Takashi Iwai wrote:
> At Tue, 6 Oct 2009 15:33:39 +0200 (CEST),
> Jaroslav Kysela wrote:
> > On Tue, 6 Oct 2009, Jaroslav Kysela wrote:
> > My other proposals:
> > - remove all SND_SCN_ defines - they are quite use-case specific
> > - the names should be just documented somewhere
> Keeping the basic and common strings makes sense, I think.
> After all, the apps need to use the correct strings.
What would you put under basic and common strings? Remove all that are gsm, bt
or ip realted for now?
> > - represent QoS with string (name) rather than integer -
> > QoS is also quite use-case specific
Hmm, what would that buy us?
> > - SND_SCN_INT_QOS may be SND_SCN_INT_QOS_POWER ?
Makes sense, done.
> > - what about to remove QOS and add universal parameter interface?
> > something like:
> > int snd_scenario_set_parameter(snd_scenario_t *scn, char *type, char *value);
> This sounds not bad, but let's argue first what parameters could be
> added in future.
Any concrete examples here? I'm not against a more generic interface, but I have
problems to see good use cases for it.
I implemented the snd_scenario_get_control_id() function you favoured over the
explicit functions. Also two more small patches posted in a new thread.
More information about the Alsa-devel