[alsa-devel] [PATCH V2] Add i.MX sound support

javier Martin javier.martin at vista-silicon.com
Mon Nov 30 14:13:47 CET 2009

2009/11/30 Sascha Hauer <s.hauer at pengutronix.de>

> On Mon, Nov 30, 2009 at 11:43:23AM +0100, javier Martin wrote:
> > Hi Sascha,
> > have you tested capture direction on an i.MX27 based board?
> >
> > I have been testing your patches in the place you suggested and playback
> > seems to work fine but I have several problems with capture stream. I
> found
> > a BUG in the audmux_v1 code
> > and I have fixed it but I am still having problems with capture. The file
> > keeps empty and nothing is recorded.
> Capture works fine on my boards.
> > Please could you try the following on an i.MX27 based board?
> >
> > arecord -t raw -c 1 -f S16_LE test.wav
> Does it work with two channels? Do you use DMA or FIQ? Could you try the
> other variant?

 Unfortunately, I can't test it using two channels because our board has a
wm8974 mono codec. Please could you point me how can I change between FIQ
and DMA? I thought FIQ was only for AC97,

It helped me a lot during development to use a tool like memedit
> (http://www.pengutronix.de/software/memedit/index_en.html) to show a
> register dump of the SSI/Audmux units of a working setup and a non
> working setup. Usually the differences showed quite fast why one was
> working and the other was not.

 Indeed, this will be my next step.

 Thank you for the tip.

Javier Martin
Vista Silicon S.L.
CDTUC - FASE C - Oficina S-345
Avda de los Castros s/n
39005- Santander. Cantabria. Spain
+34 942 25 32 60

More information about the Alsa-devel mailing list