[alsa-devel] [PATCH] ASoC: AM3517: Fix AIC23 suspend/resume hang

Mark Brown broonie at opensource.wolfsonmicro.com
Fri Nov 27 12:42:46 CET 2009

On Fri, Nov 27, 2009 at 01:37:54PM +0530, Aggarwal, Anuj wrote:

> [Aggarwal, Anuj] We were able to fine tune NFS and use arecord to capture
> large files. But some more problems cropped up when tried to suspend /
> resume. Basic playback is working fine wrt suspend/resume. But capture,
> either tried independently or with playback, is creating a system wide
> hang. I fixed that infinite-loop in resume path but I believe something
> else needs cleanup too.
> Any pointers? 

Have you got CONFIG_DETECT_SOFTLOCKUP turned on?  With any luck that
will at least pinpoint where the code has locked up.  Otherwise it's
going to be a case of bisection via printk().

A contrast and compare of the hardware initialisation on initial boot
compared to coming out of suspend might identify the problem.  If the
playback is working it's *probably* something missing in the CPU init
that's specific to capture.

More information about the Alsa-devel mailing list