[alsa-devel] [PATCH] ASoC: AM3517: Fix AIC23 suspend/resume hang

Aggarwal, Anuj anuj.aggarwal at ti.com
Thu Nov 26 15:56:44 CET 2009

> -----Original Message-----
> From: Mark Brown [mailto:broonie at opensource.wolfsonmicro.com]
> Sent: Thursday, November 26, 2009 3:53 PM
> To: Aggarwal, Anuj
> Cc: 'Troy Kisky'; alsa-devel at alsa-project.org; linux-omap at vger.kernel.org;
> Arun KS
> Subject: Re: [alsa-devel] [PATCH] ASoC: AM3517: Fix AIC23 suspend/resume
> hang
> On Thu, Nov 26, 2009 at 08:31:11AM +0530, Aggarwal, Anuj wrote:
> > I have already tried that but it doesn't fix the problem entirely.
> > Still, I was not able to playback properly because the bias settings
> > were not handled correctly and as you can see, it writes to some
> > invalid registers too (all registers don't exist between 0 and
> Please also note the following patch which is queued for 2.6.32:
> commit 50b6bce59d154b5db137907a5c0ed45a4e7a3829
> Author: Mark Brown <broonie at opensource.wolfsonmicro.com>
> Date:   Mon Nov 23 13:11:53 2009 +0000
>     ASoC: Fix suspend with active audio streams
[Aggarwal, Anuj] I am also seeing one more problem with the original 
driver, although I am not sure if the problem is in the audio driver. 
When tried to capture, using NFS as storage, it gives overrun error and comes out with:
arecord: pcm_read:1617: read error: Input/output error

It happen always after ~20 sec, file size ~5MB. Tried with multiple
configurations in arecord but no use.
When tried: arecord -f cd /dev/null, it works fine. Same issue doesn't 
come too when I try to store the captured audio file on a MMC card.

Any idea what could be the problem? Why arecord goes for a toss after a 
single overrun error and why it is happening always after ~20 sec? Is
there something which can be tried to narrow down the problem?

More information about the Alsa-devel mailing list