[alsa-devel] [PATCH 1/7] S3C AUDIO: Rename s3c24xx_pcm prefix to s3c_dma
broonie at opensource.wolfsonmicro.com
Fri Nov 6 17:23:23 CET 2009
On Thu, Nov 05, 2009 at 02:03:08PM +0900, Joonyoung Shim wrote:
> On 11/5/2009 1:16 PM, jassi brar wrote:
> > but if we try so, we have the following
> > 1) s3c24xx_pcm_dma_params -> s3c_dma_dma_params
> > 2) s3c24xx_pcm_preallocate_dma_buffer -> s3c_dma_preallocate_dma_buffer
> > 3) s3c24xx_pcm_dmamask -> s3c_dma_dmamask
> > none of which seem very nice.
> You can modify the names for the consistent prefix. If you
> use s3c_dma_ prefix, for example, s3c24xx_pcm_dma_params can be to
I tend to agree with this. The actual rename needs to happen to free up
the PCM name for the driver for the PCM hardware.
> > These patches is not about changing naming conventions. Only changes, necessary
> > to have a clean and consistent namespace after integrating PCM driver, have
> > been made.
> Agree, but you already are changing the prefix from s3c24xx to s3c.
I also agree with this - if we're renaming this driver anyway then
changing the prefix for it while we're at it seems reasonable, it means
one less change in the future.
More information about the Alsa-devel