[alsa-devel] [PATCH] sound/soc/codecs: Add support for the wm8727 DAC.

Neil Jones neiljay at gmail.com
Mon Nov 2 14:21:01 CET 2009

On Mon, Nov 2, 2009 at 12:09 PM, Mark Brown <
broonie at opensource.wolfsonmicro.com> wrote:

> On Mon, Nov 02, 2009 at 11:54:15AM +0000, Neil Jones wrote:
> Thanks for this - there's a few relatively minor issues below.
> Please remember to CC maintainers on patches, this helps avoid them
> getting missed on busy mailing lists.

  Ok no probs, are you the maintainer ?

> Your MUA has word wrapped your post - this is going to upset patch.
> There are some hints on MUA configuration in
> Documentation/email-clients.txt
> which might help.  If all else fails an attachment (without a copy of
> the patch in the body of the mail) usually works.

   Again ok, I've tried my gmail acount this time, as i have similar problem
   patches sent via exchange.

 You might want to run your patch through scripts/checkpatch.pl - I think
> there's some indentation issues (I'm not 100% sure that this isn't your
> MUA mangling things, though).
> I did its clean just email client no doubt.
> This should be converted to register a platform driver for the device
> and do the DAI registration.  Some older drivers don't do this but it
> will be required going forward for newer framework features so it's
> mandatory for new drivers.
> See wm8350 for an example of registering off a platform driver probe,
> it's just a case of calling the register/unregister functions from the
> platform driver probe/remove functions and assigning dai->dev to be the
> struct device for the platform driver before you register the DAI.

   No probs, cheers for the feedback.

More information about the Alsa-devel mailing list