[alsa-devel] Conexant CX20561 - Microphone problems

Takashi Iwai tiwai at suse.de
Mon Nov 2 14:05:37 CET 2009

At Thu, 29 Oct 2009 18:59:40 -0400,
Shawn Starr wrote:
> Hello ALSA developers, 
> I am having problems with the microphone on the following hardware this is on 
> a Lenovo W500 laptop.
> Card: HDA Intel                                                                                   
> Chip: Conexant CX20561 (Hermosa)
> Here is the problems im noticing:
> 1) If I use ALSA 'default' with the microphone I get noise interference on 
> output [high/low/high/low]. 
> If I switch this to use the "ALSA Capture on HDA Intel [CONEXANT Analog] I get 
> interference except it is the standard 60Hz electrical noise [steady noise]
> 2) Using the internal/external microphones gives an inconsistent volume. It 
> also does not seem to work with the microphone cutting out so much. I need to 
> adjust Digital + another microphone but it still drops capturing.
> Alsamixer shows:  Digital/Docking Microphone/External Microphone/Internal 
> Microphone
> Here is the module options I give to the sound driver:
> options snd-intel-hda enable_msi=1 power_save=10 power_save_controller=true 
> model=laptop index=0
> Assuming power saving/controller causes the microphone to cut out or not.
> 3) I'm now aware that this card has no pinouts for PCM capture 
> https://bugzilla.redhat.com/show_bug.cgi?id=502293

Could you give alsa-info.sh output?  Run with --no-upload option, and
attach the generated file.



More information about the Alsa-devel mailing list