[alsa-devel] [PATCH 0/2] ASoC: TWL4030: DAPM restructuring and Headset pop-attenuation fix

Peter Ujfalusi peter.ujfalusi at nokia.com
Tue May 19 10:00:29 CEST 2009

On Tuesday 19 May 2009 09:47:13 ext Aggarwal, Anuj wrote:
> I am facing problems on the capture side now, I don't know whether someone
> has tested it or not.
> By default, capture was not working. I have to enable Analog Left Capture
> Route AUXL & Analog Right Capture Route AUXR to enable the capture
> paths for OMAP3 EVM. Even after enabling both the paths, I am not able to
> capture audio on both the channels. I am hearing audio only on either of
> the channel, the other one is playing only noise for me. (This channel
> swapping is random, sometimes it plays on left and sometimes on right.)
> If I disable ' Analog Right Capture Route AUXR', I am not hearing any
> noise; audio is playing fine, but again on either of the channels, not
> consistently on the left one.
> Moreover, in both the cases, I am getting large overrun errors (I am using
> NFS to store the recorded clips, will try with MMC etc. too):
> root:~# arecord -f cd -d 30 rec05.dat
> Recording WAVE 'rec05.dat' : Signed 16 bit Little Endian, Rate 44100 Hz,
> Stereo overrun!!! (at least 8424.774 ms long)
> overrun!!! (at least 6465.943 ms long)
> overrun!!! (at least 3377.716 ms long)
> overrun!!! (at least 7982.147 ms long)
> overrun!!! (at least 8649.720 ms long)
> I didn't face both the problems on my original code base (2.6.29-rc3) and
> hence wanted to confirm whether someone else has also faced the same
> issues. I am debugging at my end to see what difference is causing the
> problem but any pointers are welcome.

I have sent a patch, which should get the AUXR working again.

> Thanks and Regards,
> Anuj Aggarwal

More information about the Alsa-devel mailing list