[alsa-devel] [PATCH 0/2] ASoC: TWL4030: DAPM restructuring and Headset pop-attenuation fix

Jarkko Nikula jhnikula at gmail.com
Tue May 19 09:33:16 CEST 2009

On Tue, 19 May 2009 09:46:40 +0300
Peter Ujfalusi <peter.ujfalusi at nokia.com> wrote:

> On Monday 18 May 2009 18:28:52 ext Aggarwal, Anuj wrote:
> > [Aggarwal, Anuj] I tried this on OMAP3 EVM. Ramp delay values 0-3
> > produces minor glitches in the beginning & end, value 4 gave me the
> > best result so far on my EVM, I will try with some other EVMs as
> > well before finalizing it. 5 and others produce a beep in the
> > beginning and end. Just one question, is there any side-effect of
> > choosing a large ramp delay? For e.g. in my case, it could be 437ms
> > (19.2MHz clock).
> It is less than half a second ;)
> I'm not sure, but we could try later to add a timer to finish up the
> ramp- down.
> There could be (not foreseen) side effects...
> At this point I think this (series) is a good start and it is better
> than what we had.
For my Beagle the power-up/-down low-frequency pop goes more silent as
the ramp time increases. Sharp power-down snap is there with '27/20/14
ms' and '55/40/27 ms' but not times above.

Beep sound is here when ramp is '109/81/55 ms' and above. As ramp time
increases, the beep sound frequency goes down. Codec HW issue?

I don't have any objections to these two patches and as the music still
plays fine so probably these can be pushed in safely.


More information about the Alsa-devel mailing list