[alsa-devel] CA0106 mic not working, logs attached

Steven Edwards cureadvocate at gmail.com
Thu Mar 26 01:52:54 CET 2009

Dear ALSA,

I installed Ubuntu 8.10 yesterday, updating ALSA to 1.0.19 to mute my
speakers when the headset is plugged in.  I unchecked the mute below the
Microphone slider, maximized the volume, clicked Close.  Sound Recorder
detected nothing, so I returned to Volume Control->Recording and noticed
that Microphone stayed checked.  Repeat x3, same results.

I then tried the PulseAudio setup outlined by markbuntu at:


That failed, so I tried soundrecorder's ALSA upgrade script at:


This (sudo bash ./AlsaUpgrade-1.0.x-rev-1.16.sh -di) killed all sound and
aplay -l detected no sound cards.  Restore (sudo bash ./
AlsaUpgrade-1.0.x-rev-1.16.sh -r) didn't restore my speakers, so I ran


Next, retrying the update script didn't restore my speakers either.


Finally, (sudo ./configure && sudo make && sudo make install) restored my
speakers' ability to output sound, but the mic still isn't recording sound.
The original problem--Volume Recorder not accepting/remembering/allowing my
unmuted Microphone--remains.  alsa-info.sh:


I don't know where to go next.  I hope the reports help and that you will be
able to help me.



More information about the Alsa-devel mailing list