[alsa-devel] [PATCH] ALSA: drop outdated and broken sa11xx-uda1341 driver

Takashi Iwai tiwai at suse.de
Fri Mar 13 01:23:09 CET 2009

At Fri, 13 Mar 2009 00:46:47 +0300,
Dmitry Artamonow wrote:
> > Yay, someone finally removing this.
> > 
> > I never saw this going in, but when I read through it, it was totally
> > iPAQ specific.  Having seen soo much effort put in to the OSS driver
> > to make it flexible, have the iPAQ people use that, and then write
> > their own ALSA specific driver irked the people who contributed to
> > the OSS driver, to the extent that the OSS support was ripped out.  (So
> > I have platforms here were there _was_ full sound support but with the
> > advent of ALSA, lost all sound support.)  It was certainly a sad day
> > when this driver was merged.
> That saddens me most is that all this years since it was merged various
> people spent their time to do some small fixes, cleanups and API conversion
> in this driver, and nobody ever noticed that it can't even be compiled.

It could be still built with alsa-driver tree, which works for 2.2 and
2.4 kernels (unfortunately 1.x and 2.0 kernels aren't supported ;)
But it doesn't make sense to keep the code in 2.6 tree, of course.
So now it's moved into out-of-kernel tree again.



More information about the Alsa-devel mailing list