[alsa-devel] ALC889A (Gigabyte EX58-UD5) pin support

Vedran Miletić rivanvx at gmail.com
Fri Mar 6 10:01:54 CET 2009

Have you tried ALSA snapshots? They might work better i.e. more permanent.

Nice board, BTW.

Vedran Miletić

2009/3/6 Jo Shields <directhex at apebox.org>:
> On Fri, 2009-03-06 at 01:19 +0000, Jo Shields wrote:
>> I've got a pretty new Gigabyte board, using snd-hda-intel and an ALC889A
>> chip. Whilst the chip seems to be detected fine, I have no functional
>> audio out - no sound on any of the ports.
>> dmesg shows that ALSA has no idea about the specific model:
>> HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
>> hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
>> If I'm reading the source correctly, the default pin layout is
>> 3stack-digout. I tried 6stack-digout, but it didn't help.
>> Linked is output from the diagnostic script:
>> http://www.alsa-project.org/db/?f=3938bc16481f549203e373e303c4b1c1dfb303dd
>> I'm happy enough to try things out in an effort to get the onboard sound
>> to behave
> Scratch that - it seems to have decided to start working after I messed
> with some of the switches. Oddly, it's identical to one time when it was
> merely popping and clicking (plugging something into the front-panel
> audio helped, but the fix seems to hold between cold-boots)
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at alsa-project.org
> http://mailman.alsa-project.org/mailman/listinfo/alsa-devel

More information about the Alsa-devel mailing list