[alsa-devel] Plugging in headphones doesn't mute speakers, internal microphone does not work

Emilio López buhitoescolar at gmail.com
Tue Mar 3 00:47:03 CET 2009


I tried with the alsa-driver snapshot without any model option, and now the
headphones mute the speakers. But the internal microphone doesn't still
work, and 'Side' doesn't output sound like it did before, even if it's
unmuted and with volume at 100% (with the old version and without any model
option, it worked)

Any thoughts? If you need any other info about my system, don't hesitate to
ask for it :)

Looking forward to hearing from you, and thanks in advance!


2009/3/2 Takashi Iwai <tiwai at suse.de>

> At Sat, 28 Feb 2009 14:38:10 -0200,
> Emilio López wrote:
> >
> > Hello,
> >
> > This is my first mail to the list, I hope you can help me. I have been
> > talking with people on #alsa, but they couldn't help me, so that's why
> > I'm writing to you.
> >
> > Well, as lspci says, my Acer Aspire 6930 laptop has an "Intel
> > Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)". With
> > this card, and without adding any mode=... to
> > /etc/modprobe.d/alsa-base, playback works perfectly, but when I plug
> > in headphones, the integrated speakers do not mute. I can mute the
> > speakers muting "front" and "side" and use the headphones, but it
> > should be automatic.
> >
> > Setting mode=auto makes the headphones, when plugged, mute the
> > speakers. But the problem with this is, that when using the speakers,
> > I only get sound from the speaker that was "front" in the other mode.
> > The microphone does not work in this mode either.
> >
> > I also tried other modes, including (but not limited to) acer,
> > acer-aspire. I ran alsa-info.sh, here is the URL:
> >
> http://www.alsa-project.org/db/?f=7910da439e8e190a8c2a6f18167d4879c74881c9
> >
> > And before I forget, regarding the microphone, if I plug an external
> > one on the microphone plug, I can record. And I tried the internal one
> > on windows, and it works, so I believe it's an alsa problem.
> >
> > Looking forward to hearing from you!
> Could you check the very latest sound git tree or alsa-driver snapshot
> below, first without model option?
>  git://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound-2.6.git
> ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/snapshot/alsa-driver-snapshot.tar.gz
> thanks,
> Takashi

More information about the Alsa-devel mailing list