[alsa-devel] Problems with snd-hda-intel and Asus M2NPV-VM. Please help!

VDR User user.vdr at gmail.com
Tue Jun 30 19:30:25 CEST 2009

On Tue, Jun 30, 2009 at 2:35 AM, Takashi Iwai<tiwai at suse.de> wrote:
> At Mon, 29 Jun 2009 10:28:24 -0700,
> VDR User wrote:
>> On Mon, Jun 29, 2009 at 12:27 AM, Takashi Iwai<tiwai at suse.de> wrote:
>> > Try the very latest alsa-driver snapshot before doing any debugging.
>> >    ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/snapshot/alsa-driver-snapshot.tar.gz
>> >
>> > If this still doesn't work, run alsa-info.sh with --no-upload option,
>> > and attach the generated file.  I'll start checking after this.
>> Thanks for your reply!  I have downloaded the link, compiled, and
>> installed.  Results are the same, spdif is not working.
> How did you play via SPDIF exactly?
> Doesn't the following work (even without model option)?
>        % aplay -Dplug:spdif some-48k-samples.wav

I have tried that exact command and also using -Dplug:iec958, without
success.  I tried both as user and using sudo from console and console
with x loaded.  Also with/without the model option and position_fix=1
option.  Is it possible the revision of the MCP51 I have is not
supported (yet)?  Please let me know anything further I can do to help
figure this out.

Many thanks!

More information about the Alsa-devel mailing list