[alsa-devel] Regarding Sound on Acer Aspire 6935G

Tony Vroon tony at linx.net
Wed Jun 24 00:40:09 CEST 2009

On Tue, 2009-06-23 at 15:05 -0300, Emilio López wrote:
> I had a little free time, so I decided to play a little with alsa. I
> copied the mic verbs from the old model to this new one and it seems
> to be working fine. Here is the patch for that

Takashi, please feel free to apply this. Especially the PIN_IN selector
is obviously correct, and if this fixes the 6935 it should work on the
Unfortunately the 6930 (which isn't mine) will be out of the country as
of tomorrow.

Emilio, you may want to resubmit with a Signed-Off-By line etc. There's
a Documentation/SubmittingPatches in the kernel source that explains all
the little details.

> Now, the only 'broken' thing is jack sensing, it just mutes front, but
> not LFE. I guess this is an easy to fix issue.

Now that you've got your hands dirty you might want to fix that one as
well :)
You'll want to mute/unmute node 0x17 (the "tuba") in addition to 0x14 in
the jack sense handler. Might as well handle 0x16 now that you're at it,
the codec graph suggests this is a speaker of some kind as well. Copy
alc888_acer_aspire_4930g_init_hook into a new 6930g_init_hook, and look
at 8930g to see how to do multiple speaker nodes.

That's basically it. Hacking on patch_realtek.c is quite doable.

> Emilio

Tony V.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20090623/be77020f/attachment.sig 

More information about the Alsa-devel mailing list