[alsa-devel] Problems with X-Fi driver

Daniel Bankmann daniel_bankmann at arcor.de
Mon Jun 1 14:10:37 CEST 2009

Takashi Iwai schrieb:
> At Fri, 22 May 2009 11:54:47 +0200,
> Daniel Bankmann wrote:
>> Takashi Iwai schrieb:
>>> At Thu, 21 May 2009 09:53:23 +0200,
>>> Daniel Bankmann wrote:
>>>> Hi!
>>>> I just tested the newest driver version with Open Suse 11.1 and
>>>> pae-kernel. I seems not to work probably, although the latest
>>>> driver by Creative worked more or less good.
>>>> The problem is, that always, when hearing some music or any other
>>>> the signal gets interrupted every few seconds. At the other side, the
>>>> startup jingle for example is accompanied by a knock every few seconds.
>>>> Any idea, or what information do you need to fix this?
>>> If you are using pulseaudio, try to upgrade to the one in Factory.
>>> PA on 11.1 is really a crappy version, unfortunately.
>>> Takashi
>> Hi,
>> are you sure, that this is a problem with PA?
> Depends on your system setup.  As default, PA is used on KDE and GNOME,
> regardless of h/w multi-stream functions.
>> Upgrading to the newest
>> version or the one in Factory seems to be a bit tricky (because auf
>> missing dependencies).
> You can upgrade the packages on OBS multimedia:libs repo.
>> Shouldn't the driver just work without PA and ESD installed? I tried
>> that out, but the problem still resists.
> It's not the driver to decide whether to use PA or not.  It's the
> upper part.
> If the problem still occurs without PA (and you make sure that you
> don't use it), the issue is likely the hwptr update timing of the
> ctxfi driver.   The recent PCM core has a more strict check, and
> possibly ctxfi might not provide the correct DMA position.
> Anyway, please check the problem occurs with which apps more exactly.
> At best, try to reproduce with aplay and speaker-test programs, i.e.
> with less complexity.  And, please report back to alsa-devel ML.
> (Note that your post may appear later after manual approvals if you
>  aren't subscribed yet).
> thanks,
> Takashi


so I tried reproducing this problem. Here's a link to a wav-file which
includes tests with aplay and the starting/shutdown -jingle.

I hope this can give you a better idea of my problem;)



More information about the Alsa-devel mailing list