[alsa-devel] No sound with nVidia Corporation MCP79 High Definition Audio (rev b1) (Macbook Pro 5, 5)

Sean Burke leftmostcat at gmail.com
Mon Jul 6 19:16:35 CEST 2009

Scríobh Takashi Iwai:
> At Mon, 6 Jul 2009 17:53:46 +0200,
> Andreas Nüßlein wrote:
>>> The missing pin configuration initialization was already fixed by
>>> the driver overriding it after checking PCI SSID (which is different
>>> from the codec SSID).  So, this should be no problem.
>>> However, the reason why the analog output doesn't work might be
>>> different from that.  There might be something else missing, but I
>>> don't know.
>>> Takashi
>> oh =(
>> hmm.. anything i can do?  would it help if i tried changing values randomly 
>> with hda-analyzer.py?
> Well, did the driver without my change work more or less with
> the analog audio, or have you never gotten the analog output?
> You can use the generic parser (i.e. the state without cirrus patch)
> by passing model=generic option to snd-hda-intel.
For my part, nothing worked with the generic driver. I can't confirm
digital out, but I can confirm that the kfree error is gone. What
options are open for figuring out what remains?


More information about the Alsa-devel mailing list