[alsa-devel] Testers wanted: New SB X-Fi driver

Christian Esken esken at kde.org
Sun Jul 5 00:19:55 CEST 2009

Am Samstag 27 Juni 2009 14:05:45 schrieb Christian Esken:
> Hello,
> unfortunately I cannot playback anything (PCM) with the new SB X-Fi driver.
>   Driver: ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/snapshot/alsa-
> driver-snapshot.tar.bz2
>   Distribution: openSuSE 11.1
>   Kernel:
> My card is a "X-Fi Titanium" (PCI device code: 1102:000b). The card is
> recognized by the driver, and any mixer (alsamixer, kmix) also recognizes
> the card.
> But playing back isn't possible. I tried speaker-test, audacity, amarok and
> aplay. Most applications  hang, some also produce an error in the
> /var/log/messages (see
> below).
> I then used "./configure --with-debug=full --with-cards=ctxfi" due to the
> possible hd-audio conflict, but it didn't make a difference.
> Is there anything else I could try?

I tested the same openSuSE version with a non-Xen 64 bit kernel, and it 
doesn't work either.

And I tried with this:
  Driver: alsa-driver-20090704.tar.bz2
  Distribution: Kubuntu Karmic Alpha-2
  Kernel: 2.6.30  (32 Bit)

Under the latter setup the X-Fi Titanium works (Simple 2 channel test with 
speaker-test, audacity, amarok). :-))

What I now know/believe is this:
- Alsa driver : not responisible (it works)
- My Computer hardware : not responsible (it works)
 - Xen kernel: quite likely not responsible
 - Kernel < 2.6.30: Probably responsible
 - 64 Bit: Probably responsible
- Other less likely stuff like NVIDIA driver (nv vs nvidia): Could be checked

I will now check other combinations. Next will be Kernel 2.6.30 (64 bit), 
using openSUSE 11.2-Milestone3.


More information about the Alsa-devel mailing list