[alsa-devel] 'node->type == SND_CONFIG_TYPE_COMPOUND' failed

Michael Hirsch m.hirsch at phase-zero.de
Mon Jan 12 17:12:03 CET 2009

Hello all,

I'm trying to get alsa 1.0.16 working on a ARM PXA processor and I'm 
stuck with the following error message:

aplay: conf.c: 3166: snd_config_iterator_first: Assertion `node->type == 

kernel version matches the user space library and utils version.

searching the archives / google brings no result.

We tried with an empty alsa.conf but then the message:

ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM default
aplay: main:564: audio open error: No such file or directory

appears. However the card shows up /proc/asound/cards and alsamixer is 
able to access it.

Any ideas?

Best regards


More information about the Alsa-devel mailing list