[alsa-devel] Bug tracking help wanted (Re: alsa driver #2234 SoundScape Elite not support)

Krzysztof Helt krzysztof.h1 at poczta.fm
Thu Jan 8 22:57:11 CET 2009

On Wed, 7 Jan 2009 19:13:18 -0500
"Theodore J. Allen" <tjallen at hws.edu> wrote:

> Hi Krzysztof,
> Yes, the Soundscape Elite does have the AD1848KP chip.
> I compiled the 2.6.28 kernel and enabled the snd-sscape
> module, though I compiled the rest of the ALSA code into
> the kernel.  It is closer, but not there yet; I get some
> noise (clicks) from the card when trying to access it but
> no sound.  I ran the alsamixer and I also tried to upload
> firmware with the sscape_ctl program, but the only message
> I get from doing that is "ALSA sound/isa/sscape.c:536:
> sscape: No response from on-board processor after upload"

It seems that the codec is detected correctly now so try running 
alsamixer, set volume to non-zero level (maximum is the best for 
the first trial but will be too loud probably) then use aplay 
command to play any sound. Do not upload card's firmware as
it maybe needed only for MIDI playback (OSS driver does not
need it). Let's try running the digital playback and recording
without the midi part first.

What is error message produced if you try using aplay? Is there
anything new in the dmesg file?

I will try comparing the source of the free OSS driver to find
out is there any additional actions inside driver required for the 
Elite card.


Znamy wszystkie lekarstwa na nude! Przekonaj sie sam.
Kliknij >>  http://link.interia.pl/f200d

More information about the Alsa-devel mailing list