[alsa-devel] alsa-lib-1.0.18 doesn't build with option '--with-softfloat'

Mark Brown broonie at sirena.org.uk
Wed Jan 7 12:34:27 CET 2009

On Wed, Jan 07, 2009 at 12:13:22PM +0100, Takashi Iwai wrote:
> Mark Brown wrote:
> > On Wed, Jan 07, 2009 at 10:18:42AM +0100, Takashi Iwai wrote:

> > OpenEmbedded has been carrying the following patch for a while,
> > cooindcidentally I was actually looking at their ALSA packaging last
> > night and thinking about pushing this to you - it forces liking with
> > libm which is more important when using softfloat.

> Well, when softfloat option is chosen, basically alsa-lib should be
> built without floating operations, thus libm shouldn't be needed.  (So
> in that sense, the option is named wrongly...)

Yeah, looking at the code I had kind of suspected that or I'd have
pushed it last night.  It's probably worth renaming the option to
"float" or something to reduce confusion?

More information about the Alsa-devel mailing list