[alsa-devel] Plugging in headphones doesn't mute speakers, internal microphone does not work

Emilio López buhitoescolar at gmail.com
Sat Feb 28 17:38:10 CET 2009


This is my first mail to the list, I hope you can help me. I have been
talking with people on #alsa, but they couldn't help me, so that's why
I'm writing to you.

Well, as lspci says, my Acer Aspire 6930 laptop has an "Intel
Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)". With
this card, and without adding any mode=... to
/etc/modprobe.d/alsa-base, playback works perfectly, but when I plug
in headphones, the integrated speakers do not mute. I can mute the
speakers muting "front" and "side" and use the headphones, but it
should be automatic.

Setting mode=auto makes the headphones, when plugged, mute the
speakers. But the problem with this is, that when using the speakers,
I only get sound from the speaker that was "front" in the other mode.
The microphone does not work in this mode either.

I also tried other modes, including (but not limited to) acer,
acer-aspire. I ran alsa-info.sh, here is the URL:

And before I forget, regarding the microphone, if I plug an external
one on the microphone plug, I can record. And I tried the internal one
on windows, and it works, so I believe it's an alsa problem.

Looking forward to hearing from you!


More information about the Alsa-devel mailing list