[alsa-devel] ALI5451: "stimer is not ready"

hagedorn at kimae.de hagedorn at kimae.de
Tue Feb 17 18:28:49 CET 2009

Dear All,

since our hardware supplier changed the processor type from Transmeta T5700 
(667MHz) to T5800 (997MHz), we experience massive problems with the sound 
card access. 

With the new T5800 processor we first noticed problems with IDE access. But it 
can be solved by switching "acpi=off" and choosing another processor type in 
kernel config, e.g. 'Pentium MMX' instead 'Transmeta Crusoe'. 

Moreover we experienced random appearance of
 "ali_stimer_read: stimer is not ready" 
messages from ALSA when accessing the sound card on T5800.
I tried also 2.4.37 and 2.6.22 kernels. An update to ALSA 1.0.19 does not help 
The strange thing is that i can boot the same system over and over again...
in some cases i get above error message, sometimes i get no ALSA error message 
at all but the sound card can not be accessed, and sometimes the system works 
and is recording sound - at least for a few hours.
Loading the kernel module trident instead of ALSA makes the system freeze 
immediately on a T5800. On a T5700 it works.
System yields regulary " i8253 count too high ! resetting " but does not  
seem to have any effect on system with T5700. On T5800 this messages is much 
more often. On 2.6.22 kernel i saw "TSC unstable" at boot time.

I do not have knowledge about these timing things, so i would like to know
a) what does above message mean exactly?
b) what timing source is alsa using and how can i influence it?
c) what timing source is the kernel using and how can i influence it?
d) can this be caused by defect hardware or buggy BIOS?
e) do you have any other ideas (e.g. kernel options)?

Some info about the original system which worked well on T5700:

- Linux is self-compiled with 'Linux from Scratch'
- System boots from Compact Flashdisk, HDD is used for log files only
- Kernel 2.4.22, optimized for Transmeta crusoe
- Glibc version 2.3.2, compiled with GNU CC 3.3.3 for i686 on Kernel 2.4.25 
- ALSA 1.0.5a, loaded modules are snd, snd-ali5451, soundcore, snd-pcm
 snd-timer, snd-page-alloc, snd-ac97-codec

The same compact flashcard containing this configuration on a T5800 system 
will yield IDE errors "DRQ after issuing write" and will show the stated ALSA 
stimer error.

Thank you very much in advance.
Kind regards,

More information about the Alsa-devel mailing list