[alsa-devel] [Fwd: HP DV4 1155 SE - No Sound through speakers...]

Takashi Iwai tiwai at suse.de
Mon Feb 16 11:48:24 CET 2009

At Sat, 14 Feb 2009 17:13:55 -0200,
Herton Ronaldo Krzesinski wrote:
> On Saturday 14 February 2009 08:24:15 Takashi Iwai wrote:
> > At Fri, 13 Feb 2009 14:22:00 -0500,
> > Tim Barnette wrote:
> > > 
> > > ..And it worked!  I now have sound!  Can you tell me what I actually did here?
> > 
> > The problem was that your BIOS didn't set the correct default pin
> > configuration.  The driver doesn't know which pin should be used for
> > the speaker output, as a consequence, it's set as INPUT.
> > Now you set it OUTPUT manually by hda-verb, and (fortunately) the
> > route to that pin was alive even though it wasn't declared, you get
> > the speaker output now.
> > 
> > The next step is to implement a proper pin-config to override by
> > the driver.  This won't be much work, but hey, wait for a while.
> > 
> > (Or, did Herton already work on that?)
> I had added before pin configs for which source came from *.ini files of IDT
> windows drivers provided by HP. But I don't know if they are at all necessary,
> may be just setting config of 0x0d pin should suffice for all hp-dv5 models,
> as all of them have speaker on 0x0d from all reports and also looking at the
> *.ini files.
> I have three patches, you can choose one of them :), see attached. The first
> one is my previous pin configs work "let's set for all cases the pin configs
> based on *.ini files", the others are same smaller change/less intrusive that
> instead just deals with this hp dv4 case.

I took the last, the smallest one.  It's not too bad to define all
models, but at this stage, I'd like rather to slim the code down.



More information about the Alsa-devel mailing list