[alsa-devel] Patch for Asus z37e (1043:8284)

Mackenzie Morgan macoafi at gmail.com
Mon Feb 9 18:21:19 CET 2009

A bug was reported in Ubuntu a while ago about Asus Z37E not having
audible sound after resuming from suspend/hibernate[1].  A git changeset
signed off by Daniel T. Chen and myself [2] was accepted and is in the
last 2 Ubuntu releases along with the development one.  

I filed a bug [3] in ALSA with a patch attached, then realized that the
surrounding lines wouldn't match up in trunk so updated the patch and
put it in the bugtracker and tried to email it here.  The email didn't
pass moderation, but now I'm trying again as a subscriber.

It's just an addition to the quirks table for patch_realtek.c to set
2043:8284 to use 6stack-dig.

I'm trying to get this accepted here so that Ubuntu's not the only
distro where sound works consistently across suspend/resume cycles.

[1] https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/25896

Mackenzie Morgan
apt-get moo
-------------- next part --------------
A non-text attachment was scrubbed...
Name: z37e.patch
Type: text/x-patch
Size: 788 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20090209/126da46a/attachment.patch 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20090209/126da46a/attachment.sig 

More information about the Alsa-devel mailing list