[alsa-devel] Audio capture not working with AIC23/McBSP1 on OMAP3517

Aggarwal, Anuj anuj.aggarwal at ti.com
Wed Aug 26 15:19:51 CEST 2009

> -----Original Message-----
> From: Mark Brown [mailto:broonie at opensource.wolfsonmicro.com]
> Sent: Wednesday, August 26, 2009 6:34 PM
> To: Aggarwal, Anuj
> Cc: linux-omap at vger.kernel.org; alsa-devel at alsa-project.org
> Subject: Re: [alsa-devel] Audio capture not working with AIC23/McBSP1 on
> OMAP3517
> On Wed, Aug 26, 2009 at 06:30:52PM +0530, Aggarwal, Anuj wrote:
> > I am trying to capture audio through LineIn on my OMAP3517 EVM, using
> > AIC23 codec and McBSP1, and getting the following error:
> > arecord: pcm_read:1529: read error: Input/output error
> That suggests that DMA isn't happening - might be worth checking to see
> that clocks are being generated properly.
I am able to see the bit clock and frame sync coming properly.
> > Playback is working fine using the same combination.
> > I have tried using another instance of AIC23 codec which uses McBSP2
> > and both playback & capture works fine there.
> > Has anyone faced this issue before? Any suggestions?
> Which kernel are you using?  There are rather a lot of McBSP changes
> queued up for 2.6.32.  If this ever worked in the past a git bisect
> might be interesting.
I am on 2.6.31-rc5. I have to check whether the new patches fix 
anything related to this.

More information about the Alsa-devel mailing list