[alsa-devel] hard freezes with hdsp with cardbus/pci adapter card

Tim Blechmann tim at klingt.org
Tue Aug 11 17:19:32 CEST 2009

>>> hm, actually, i think the issue is related to the pci latency of the
>>> cardbus controller.
>> Looks like it:
>> http://lkml.indiana.edu/hypermail/linux/kernel/0404.1/0602.html
>> Do you know if the increased latency is needed for all bridges, not just ENE?
>> (I'd assume so...)
> i remember that issue, it had different symptoms (distorted sound) ...
> the ene bridge seems to be the only cardbus bridge, that requires the
> increased latency, but maybe other controllers are just more robust and
> don't completely freeze the system

hm, i guess, it is not that easy ... having the hdsp running at 44.1khz,
the machine ran for several hours, but when i switch the sampling rate
to 96khz, the machine freezes quickly.

also playing with the pci latency settings of cardbus bridge and hdsp
didn't change this. from my understanding the only difference between
44.1khz and 96khz in terms of the higher bandwidth ...


tim at klingt.org

Your mind will answer most questions if you learn to relax and wait
for the answer.
  William S. Burroughs

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: OpenPGP digital signature
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20090811/cbc7f9c5/attachment.sig 

More information about the Alsa-devel mailing list