[alsa-devel] [PATCH] ASoC: SDP3430: Add support for EXTMUTE using TWL GPIO6
Candelaria Villareal, Jorge
x0107209 at ti.com
Fri Aug 7 17:33:09 CEST 2009
> -----Original Message-----
> From: Peter Ujfalusi [mailto:peter.ujfalusi at nokia.com]
> Sent: Friday, August 07, 2009 12:52 AM
> To: alsa-devel at alsa-project.org
> Cc: Candelaria Villareal, Jorge; broonie at opensource.wolfsonmicro.com
> Subject: Re: [alsa-devel] [PATCH] ASoC: SDP3430: Add support
> for EXTMUTE using TWL GPIO6
> On Tuesday 04 August 2009 09:58:15 Ujfalusi Peter
> (Nokia-D/Tampere) wrote:
> > On Wednesday 15 July 2009 04:04:08 ext Candelaria
> Villareal, Jorge wrote:
> > > Board sdp3430 has hardware support for EXTMUTE using TWL4030 GPIO6
> > > line, controlled by register INTBR_PMBR1. Machine driver
> takes care
> > > of enabling gpio line through i2c and codec driver manipulates the
> > > line during headset ramp up/down sequence.
> > >
> > > +#define TWL4030_INTBR_PMBR1 0x0D
> > > +#define EXTMUTE(value) (value << 2)
> > This is confusing, should it be something like this?:
> > #define GPIO6_PWM0_MUX(value) (value << 2)
> If you intend to change this, than GPIO6_PWM0_MUX sounds
> weird as well, in this
> way it should be GPIO6_PWM0_EXTMUTE_MUX, which not so nice...
> TWL4030_GPIO6_MUX() seams much better...
How about naming the field as it is named in TRM, GPIO6_PWM0_MUTE.
That way, if there is any confusion TWL4030 TRM should be able to
clear any doubts. Also, it states clearly whicho mode correspond to
More information about the Alsa-devel