[alsa-devel] device underruns

Daniel Mack daniel at caiaq.de
Sat Apr 25 14:23:38 CEST 2009

The posting below didn't get any response yet, but the problem persists.
Any hints, anyone?


On Tue, Mar 31, 2009 at 04:46:03PM +0200, Daniel Mack wrote:
> I'm currently stress-testing my snd-usb-caiaq driver under several
> environments and happen to see a number of such messages echoed once in
> a while at the start of aplay (1.0.16):
> underrun!!! (at least 1558380812.470 ms long)
> underrun!!! (at least 1558380818.673 ms long)
> underrun!!! (at least 1558380812.465 ms long)
> Also, pulseaudio (0.9.14) keeps complaining with the following message
> all over the place:
> E: module-alsa-sink.c: ALSA woke us up to write new data to the device,                                                                                                                                   
>    but there was actually nothing to write! Most likely this is an ALSA                                                                                                                                   
>    driver bug. Please report this issue to the PulseAudio developers.
> What puzzles me a bit is that I don't really know where and how the
> driver could confuse the core so badly. All it reports is a valid
> pointer to the current head in each substream. Is there anything else it
> could provide for tighter syncing? Any hint how to debug this? Or maybe
> it's not a bug in this specific driver but in the core somewhere?
> Thanks,
> Daniel

More information about the Alsa-devel mailing list