[alsa-devel] [PATCH] add the nvidia HDMI codec driverfor MCP77/79

Takashi Iwai tiwai at suse.de
Wed Sep 17 16:04:55 CEST 2008

At Wed, 17 Sep 2008 17:00:04 +0800,
peerchen wrote:
> new patch base on git tree.
> Signed-off-by: Wei Ni <wni at nvidia.com>
> Signed-off-by: Peer Chen <peerchen at gmail.com>


But, the patch looks like no "rebase".  You secretly added a new
function call that wasn't in your previous patch, namely...

> diff -uprN -X linux-2.6-tiwai-sound/Documentation/dontdiff linux-2.6-tiwai-sound/sound/pci/hda/hda_intel.c linux-2.6-tiwai-sound-niwei/sound/pci/hda/hda_intel.c
> --- linux-2.6-tiwai-sound/sound/pci/hda/hda_intel.c	2008-09-10 17:40:52.000000000 +0800
> +++ linux-2.6-tiwai-sound-niwei/sound/pci/hda/hda_intel.c	2008-09-10 17:49:31.000000000 +0800
> @@ -1220,6 +1220,9 @@ static int __devinit azx_codec_create(st
>  	if (err < 0)
>  		return err;
> +	if (chip->driver_type == AZX_DRIVER_NVIDIA)
> +		chip->bus->needs_damn_long_delay = 1;
> +

Do we really need this inevitably?  I don't think so -- otherwise I
would have far more bug reports.

This flag is the last resort and should be avoided as much as
possible.  This results in a significant slow down of suspend/resume
speed, for example.

If it's really needed with some devices and there is no other way to
fix it, add this flag rather in the codec-initialization part.

Also, if you resend a patch, please add the original patch description 
again.  This helps my patch work a lot indeed.



More information about the Alsa-devel mailing list