[alsa-devel] [PATCH] hda: add SW_LINEOUT_INSERT support
mranostay at embeddedalley.com
Fri Oct 17 14:53:17 CEST 2008
Mark Brown wrote:
> On Fri, Oct 17, 2008 at 08:21:17AM -0400, Matthew Ranostay wrote:
>> Mark Brown wrote:
>>> For line outputs I think providing that information in the device name
>>> would be better - the reason for providing the distinction in the switch
>>> is to provide information when the function of the device attached to
>>> the jack changes at runtime. As far as the hardware is concerned one
>>> line output is much the same as another.
>> err = snd_jack_new(codec->bus->card,
>> "Jack Detection",
>> SND_JACK_HEADPHONE | SND_JACK_LINEOUT, &spec->jack);
>> Do you mean something like this?
> I'm not sure exactly what you mean by that change. What the code says
> is that you have a single jack and can detect at runtime if the device
> plugged into it is a line or headphone. If that is the case then yes,
> you should do something like that though that's not a very good name for
> the jack (ideally it should correspond to something like the label given
> to the jack on the machine case).
Well is generally only one HP out jack, but there can be several line-out
reported by the one instance(lineout_jack). I assume this isn't the correct usage.
>> Of course this will require some changes
>> in snd_jack_report.
> Could you explain what changes you think are required? The API already
> supports multi-function jacks.
More information about the Alsa-devel