[alsa-devel] [Alsa-user] em28xx_alsa: disagrees about version of symbol xxx after upgrading CentOS 5.2 ALSA .14 for ALSA .17

Robert Vincent Krakora rob.krakora at messagenetsystems.com
Fri Oct 3 16:08:59 CEST 2008


I have searched on the web and it seems that at least one person has 
overcome the problem I am having by rebuilding soundcore.ko (See here: 
There is a sound_core.c in the ALSA tar ball. Why doesn't ALSA rebuild 
the soundcore.ko module? The functions that em28xx_alsa is complaining 
about reside in soundcore.ko according to my research. Basically, I 
downloaded .18rc3 driver, lib and util and configured, built and 
installed. I rebooted and em28xx_alsa complained that symbols that 
resided down in soundcore.ko did not jive with the versions of the same 
symbols for which it was trying to resolve linkages. I rebuilt the 
video4linux code, reinstalled and rebooted and the problem was still 
present. It looks as though one should be able to build an new 
soundcore.ko with a ALSA package but there are no instructions on how to 
do so. Please help!!!

Best Regards,
Rob Krakora
Software Engineer
MessageNet Systems
101 East Carmel Dr. Suite 105
Carmel, IN 46032
(317)566-1677 Ext. 206
(317)663-0808 Fax

More information about the Alsa-devel mailing list