[alsa-devel] Mute Beep (was Regression on alsa-driver-1.0.18a on HDA for Dell Inspiron 1521)

Manuel Naranjo manuel at aircable.net
Fri Nov 14 13:34:16 CET 2008

> Could you check the debug messages with the patch below?
> thanks,
> Takash
Sure no problem. I'm not getting any GENERATE BEEP, or BEEP EVENT on 
dmesg, just the enable disable when I press the enable disable button. 
The switch reflects the correct state.

I've gone through the patch over and over, but I can't figure out why 
would it stop working. Shouldn't the switch alert the beep part about 

Also how should I test? I tried with 'echo -e "\\a"', beep and the old 
way that was driving me crazy (pressing del in pidgin when there's no 
more text).

Anyway here's the log just in case:
snd: Not freed snd_alloc_kmalloc = 18
snd: kmalloc(9) from f8ed1d9a not freed
snd: kmalloc(9) from f8ed1d9a not freed
HDA Intel 0000:00:14.2: PCI INT A -> GSI 16 (level, low) -> IRQ 16
ALSA /home/manuel/tmp/alsa/alsa-driver/pci/hda/hda_codec.c:2596: 
hda_codec: model 'dell-m42' is selected
ALSA /home/manuel/tmp/alsa/alsa-driver/pci/hda/hda_codec.c:3312: 
autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA /home/manuel/tmp/alsa/alsa-driver/pci/hda/hda_codec.c:3316:    
speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /home/manuel/tmp/alsa/alsa-driver/pci/hda/hda_codec.c:3320:    
hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
ALSA /home/manuel/tmp/alsa/alsa-driver/pci/hda/hda_codec.c:3321:    
mono: mono_out=0x0
ALSA /home/manuel/tmp/alsa/alsa-driver/pci/hda/hda_codec.c:3329:    
inputs: mic=0xb, fmic=0x0, line=0x0, fline=0x0, cd=0x0, aux=0x0
dac_nids=1 (0x10/0x0/0x0/0x0/0x0)
input: HDA Digital PCBeep as /class/input/input18
input: HDA ATI SB at 0xfebfc000 irq 16 Mic at Ext Left Jack as 
input: HDA ATI SB at 0xfebfc000 irq 16 HP Out at Ext Left Jack as 
hda-intel: Invalid position buffer, using LPIB read method instead.

More information about the Alsa-devel mailing list