[alsa-devel] PATCH - MIDI on ice1724 - real-time kernel problem SOLVED(?)

Martin Krüger m_a_krueger at gmx.de
Mon May 26 12:54:32 CEST 2008

Pavel Hofman wrote:
> Martin Krüger wrote:
>> Pavel Hofman wrote:
>> Hi, 
>> thanks a lot for taking care for that issue. 
>> I just tried it out by modifying the following files from the 2.6.26-rc3 kernel:
>> sound/pci/Kconfig (modified by hand)
>> sound/pci/ice1712/ice1712.h (modified by hand)
>> sound/pci/ice1712/envy24ht.h (modified by hand)
>> sound/pci/ice1712/ice1724.c (copied from the actual Git snapshot)
>> I double-checked all the handmade changes, should be ok. 
>> Midi in via "amidi -p hw:0 -d" works now without problem, 
>> but when trying to write to the device, for example by "amidi -p hw:0 -s txdata.syx" 
>> it causes an immediate crash. 
>> That would not be a problem for me, but jackd probes all ports, and is unusable now.
>> Perhaps i forgot a patch, is the output working for you? 
> Hello Martin,
> I did check the MIDI output using command
> amidi -p hw:0 -S F0411042110C000000000074FF0411042110C000000
> Ubuntu Studio 7.10, both -generic and -rt kernel, Audiotrak Prodigy 192, 
> the original patch (I assume the current git version is identical).
> There was no MIDI device connected to the output as I have none.
> I traced if MIDI-out on Juli goes through the Xilinx CPLD, and it seemed 
> the MIDI lines go straight to the connectors, just as on my Prodigy 192. 
> Unfortunately, I do not have Juli available any more to test the patch.
> Please could you provide more details about the crash?
> Thanks,
> Pavel.
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at alsa-project.org
> http://mailman.alsa-project.org/mailman/listinfo/alsa-devel
Hello Pavel,

i just compiled a new kernel with realtime support. the kernel 
is from kernel.org, so without any patches except the realtime patch 
from the alsa wiki.

The alsa source i use is the actual daily snapshot, compiled with

./configure --with-isapnp=no --with-sequencer=yes --with-oss=no 
--with-debug=full --with-kconfig=ice1724
make install-modules

This version should have the patches applied, i think.

amidi -l gives the following output:
Dir Device    Name
IO  hw:0,0    ICE1724 MIDI
, and as written above, amidi -p hw:0 -d works without any problems.

The fault appears immediately after trying to write anything to the 
hw:0, this

amidi -p hw:0 -S F0411042110C000000000074FF0411042110C000000

also produces a complete freeze of the system.
No matter, if my keyboard is attached or not.

That was the first time i compiled alsa with the debugging enabled, and 
i am currently trying to find out how to use is to give you more 
information. Is there anything else i can help? I tried to trace myself 
through the source code, but my knowledge about the used api is very weak...

Thanks much for your help,

More information about the Alsa-devel mailing list