[alsa-devel] v2.6.25.3 BUG (due to usb audio device?)

Avuton Olrich avuton at gmail.com
Sat May 17 16:50:08 CEST 2008

On Tue, May 13, 2008 at 4:25 AM, Takashi Iwai <tiwai at suse.de> wrote:
> At Sun, 11 May 2008 09:53:01 -0700,
> Avuton Olrich wrote:
>> This locks up KDE due to kmixer somehow trying to stay attached to the
>> audio device after resume from suspend-to-disk. This is the second
>> time of dealing with this (or a similar bug) with the usb audio
>> device:
>> http://mailman.alsa-project.org/pipermail/alsa-devel/2008-March/006867.html
>> I got it working by using the head of the git tree recommended in that
>> thread (unfortunately I don't have the hash it was related to).
> If the recent git works, it should be the series of my patches:
> 73d38b13ffb105ab633bd91969c8d218b2de38d4
>        [ALSA] Fix the race of card instance unregistration
> f18638dcf0c481eca2430206ebcdc7295aec8623
>        [ALSA] Clean up snd_card_free*()
> 9eb70e68f38bbc5996a2193e7b7dc0b5487a08cb
>        [ALSA] usb-audio - Fix race in reconnection
> But the patches are intrusive, and I'm not keen on applying them to
> stable trees...

OK, finally had the time to try the newer master and here's what I get now;

I suspend and resume fine, but the sound card no longer works again
after resume and the only thing I see in the dmesg is:

[  125.873947] usb 3-1: reset full speed USB device using ohci_hcd and address 2
[  126.017265] snd-usb-audio 3-1:1.0: no reset_resume for driver snd-usb-audio?
[  126.017265] snd-usb-audio 3-1:1.1: no reset_resume for driver snd-usb-audio?
[  126.017265] snd-usb-audio 3-1:1.2: no reset_resume for driver snd-usb-audio?

 "I've got a fever. And the only prescription is more cowbell." --
Christopher Walken

More information about the Alsa-devel mailing list