[alsa-devel] [regression] 2.6.25-rc4 snd-es18xx broken on Alpha

Bob Tracy rct at frus.com
Mon Mar 31 00:09:56 CEST 2008

Rene Herman wrote:
> Okay, thought I'd stare at this thing a bit -- there's no specific 1888 
> documentation available it seems but I did notice something in the 1878 
> datasheet which might mean something. The docs says that bits 0-1 are don't 
> care for DMA but don't for IRQ, so could it possibly be as simple as the 
> attached?
> 1878 sheet doesn't document register 0x7f, it seems...
> Assuming it's not just this, this thing is going to require quite a bit of 
> trial and error and without the hardware this will be troublesome. I expect 
> this is not it, since the arch init code also doesn't care about bit 0 when 
> setting that same register for IRQ 5.
> If this is not it -- I'd try s/0x50/0x10/ in that line, even completely 
> commenting out the IRQ setting line (with the arch code built in) and just 
> generally frolic around 'till something blows up...
> (es18xx_trial_and_error)

As distributed, no change: still not seeing any activity on IRQ 5.  I'll
play around with it some over the next day or so.

Observed: the alsa "snd-sb8" driver works fine.  Question: how does IRQ
setup differ between the sb8 and the es18xx drivers?  If I can find some
time, I'll try to figure that out...

Bob Tracy          |  "I was a beta tester for dirt.  They never did
rct at frus.com       |   get all the bugs out." - Steve McGrew on /.

More information about the Alsa-devel mailing list