[alsa-devel] Cannot change volume on Plantronics Audio 910 USB Headset

cklein at mpi-sb.mpg.de cklein at mpi-sb.mpg.de
Tue Mar 18 16:11:17 CET 2008


I recently got a Plantronics .audio 910 USB headset.
It is correctly detected by snd-usb-audio and works, but I cannot change the
volume of the PCM output or the MIC input. When executing alsamixer -c 1,
the volumes seem to be locked and cannot be changed as usual. Unfortunately
the microphone volume is at 0, leading to very poor quality of the recorded
voice (especially in Skype, which seems to try to compensate the low volume
and fails miserably).
Does anyone know how to fix this?
I found similar reports on the internet for various usb headsets, but no
real fix for the situation.
I already asked on alsa-users some weeks ago, but did not get any response.

I tried the headset on three different PCs, all with the same result.
A desktop at work running Fedora 7, a Thinkpad R50p running debian/testing
and the 2.6.22 kernel provided in debian/testing. The third one is a Dell
precision M65 with debian/unstable.
There, I used a vanilla kernel and latest alsa drivers from the
mercurial repository when I asked on alsa-users, but in the meantime I
upgraded to and hg snapshots from 2008-03-13 06:41
(alsa-driver) and 2008:03:17 05:23 (alsa-kernel), but still got the same
On all I get some message about "no or invalid class specific endpoint
descriptor" in the kernel log (see below).
When loading the snd-usb-audio module, dmesg shows the following kernel
output (on the M65):

usb 2-2: new full speed USB device using uhci_hcd and address 5
usb 2-2: configuration #1 chosen from 1 choice
input: Plantronics Plantronics BT Adapter as /devices/pci0000:00/0000:00:1d.1/usb2/2-2/2-2:1.3/input/input10
input: USB HID v1.11 Device [Plantronics Plantronics BT Adapter] on usb-0000:00:1d.1-2
usbcore: registered new interface driver usbhid
drivers/hid/usbhid/hid-core.c: v2.6:USB HID core driver
ALSA /usr/src/kernel-modules/alsa-driver-d20080313_0641-k20080317_0523/usb/usbaudio.c:2787: 5:1:1 : no or invalid class specific endpoint descriptor
ALSA /usr/src/kernel-modules/alsa-driver-d20080313_0641-k20080317_0523/usb/usbaudio.c:2787: 5:2:1 : no or invalid class specific endpoint descriptor
usbcore: registered new interface driver snd-usb-audio

I posted the output of alsa-info.sh and lsusb -v on pastebin (both taken on
the M65).

lsusb -v:

CU, Christian Klein


Homepage:       http://www.mpi-sb.mpg.de/~cklein
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20080318/9fc57721/attachment.sig 

More information about the Alsa-devel mailing list